What’s Vulnerable › Vulnerabilities
CVE-2026-8336: Post-authentication use-after-free error in $_internalJsEmit and mapreduce commands
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-416
Description
After invoking $_internalJsEmit, which is not intended to be directly accessible, or mapreduce command’s map function in a certain way, an authenticated user can subsequently crash mongod when the server-side JavaScript engine (through $where, $function, mapreduce reduce stage, etc.) is used also in a specific way, resulting in a post-authentication denial-of-service. This issue impacts MongoDB Server v8.2 versions prior to 8.2.9 and v8.3 versions prior to 8.3.2.
Affected products
- MongoDB: from 8.2.0 before 8.2.9; from 8.3.0 before 8.3.2 — fixed in 8.2.9, 8.3.2
How to fix
Upgrade to a fixed version: MongoDB 8.2.9, 8.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8336 or the next vulnerability affects your stack