What’s Vulnerable › Vulnerabilities

CVE-2026-8340: Concrete CMS 9.5.0 and below is vulnerable to CSRF via Backend\File::approveVersion

Description

Concrete CMS 9.5.0 and below is vulnerable to CSRF via Backend\File::approveVersion. Victim with edit_file_contents permission is CSRF'd into publishing an attacker-chosen previously-uploaded version (downgrade to an older version of a file, or activation of a co-editor's unpublished version). The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.3 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks Winston Crooker for reporting.

Affected products

How to fix

Upgrade to a fixed version: Concrete CMS 9.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-8340 or the next vulnerability affects your stack