What’s Vulnerable › Vulnerabilities
CVE-2026-83534: PostgreSQL Anonymizer: Privilege escalation to superuser via anon.anonymize_database_parallel()
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-06 · updated 2026-09-09
- Weakness: CWE-250
Description
PostgreSQL Anonymizer contains a vulnerability in the anon.anonymize_database_parallel() function that allows the owner of a table to run arbitrary code with superuser privilege. The issue is fixed in PostgreSQL Anonymizer 3.2.0 and later versions
Affected products
- DALIBO PostgreSQL Anonymizer: from 1 before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: DALIBO PostgreSQL Anonymizer 3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-83534 or the next vulnerability affects your stack