What’s Vulnerable › Vulnerabilities
CVE-2026-8368: LWP::UserAgent versions before 6.83 for Perl leak Authorization and Proxy-Authorization headers on cross-origin redirects
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-522
Description
LWP::UserAgent versions before 6.83 for Perl leak Authorization and Proxy-Authorization headers on cross-origin redirects. On a 3xx response, the redirect handler strips only Host and Cookie before issuing the follow-up request. Caller-supplied Authorization and Proxy-Authorization headers are sent unchanged to the redirect target, including across scheme, host, or port changes. A redirect to an attacker controlled host therefore discloses the caller's credentials to that host.
Affected products
- OALDERS LWP::UserAgent: before 6.83 — fixed in 6.83
How to fix
Upgrade to a fixed version: OALDERS LWP::UserAgent 6.83. Check the vendor advisory for mitigations.
References
- https://github.com/libwww-perl/libwww-perl/commit/9c4aeb6f2dd32f2b7eaf2d7827cade31ea6cb2c6.patch
- https://github.com/libwww-perl/libwww-perl/pull/284
- https://github.com/libwww-perl/libwww-perl/pull/512
- https://metacpan.org/release/OALDERS/libwww-perl-6.83/changes
- http://www.openwall.com/lists/oss-security/2026/05/12/7
Get alerted when CVE-2026-8368 or the next vulnerability affects your stack