What’s Vulnerable › Vulnerabilities
CVE-2026-84021: Bold Page Builder < 5.9.8 - Contributor+ Stored XSS via bt_bb_button/bt_bb_headline/bt_bb_icon URL
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-08
- Weakness: CWE-79
Description
The Bold Page Builder WordPress plugin before 5.9.8 does not properly validate a link URL before outputting it in an HTML attribute, relying on a filter that can be evaded, allowing users with the Contributor role and above to inject arbitrary web scripts that execute when a user clicks the affected link.
Affected products
- boldthemes Bold Page Builder: before 5.9.8 — fixed in 5.9.8
How to fix
Upgrade to a fixed version: boldthemes Bold Page Builder 5.9.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84021 or the next vulnerability affects your stack