What’s Vulnerable › Vulnerabilities
CVE-2026-84098: Directorist 3.1.0 - 8.9.4 - Subscriber+ Arbitrary Listing Deletion via remove_listing
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-863
Description
The Directorist: AI-Powered Business Directory, Listings & Classified Ads WordPress plugin before 8.9.5 does not properly verify a listing's ownership before deleting it, allowing authenticated attackers with Subscriber-level access and above to delete arbitrary listings, including ones belonging to other users. This is an incomplete fix of CVE-2023-1889 / CVE-2023-35052: a separate, unaddressed listing-deletion path allows the same impact, from at least version 3.1.0 through the current release.
Affected products
- Directorist: AI-Powered Business Directory, Listings & Classified Ads: from 3.1.0 before 8.9.5 — fixed in 8.9.5
How to fix
Upgrade to a fixed version: Directorist: AI-Powered Business Directory, Listings & Classified Ads 8.9.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84098 or the next vulnerability affects your stack