What’s Vulnerable › Vulnerabilities
CVE-2026-84151: The Post Grid < 7.9.5 - Contributor+ Stored HTML/iframe Injection via wp_kses_post Allow-List Widening
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-24
- Weakness: CWE-79
Description
The Post Grid WordPress plugin before 7.9.5 does not limit an expansion of the WordPress allowed-HTML list to its own markup and applies it site-wide, allowing users with the Contributor role and above to store iframe, style and input elements that are normally stripped from their content, leading to HTML injection (phishing frames, CSS defacement and spoofed input forms) that renders to any visitor and to administrators reviewing the content.
Affected products
- RadiusTheme The Post Grid: before 7.9.5 — fixed in 7.9.5
How to fix
Upgrade to a fixed version: RadiusTheme The Post Grid 7.9.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84151 or the next vulnerability affects your stack