What’s Vulnerable › Vulnerabilities
CVE-2026-8417: Concrete CMS 9.5.0 and below is vulnerable to CSRF in do_update() in the package update controller
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-21 · updated 2026-07-23
- Weakness: CWE-352
Description
Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/update/do_update/<pkgHandle>. The do_update() method in concrete/controllers/single_page/dashboard/extend/update.php checks only canInstallPackages() before executing upgradeCoreData() and upgrade() on the named package's controller. Because the endpoint is a state-changing GET route with no token enforcement, an attacker can force an authenticated administrator to trigger a package upgrade via a single cross-site navigation.In order to be vulnerable, the victim must be passing canInstallPackages() and and a target package must already be already installed. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks https://github.com/maru1009 for reporting.
Affected products
- Concrete CMS: before 9.5.1 — fixed in 9.5.1
How to fix
Upgrade to a fixed version: Concrete CMS 9.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8417 or the next vulnerability affects your stack