What’s Vulnerable › Vulnerabilities
CVE-2026-84188: librenms before 26.7.0 Stored XSS via graph_descr settings
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-10-08
- Weakness: CWE-79
Description
LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.
Affected products
- librenms: before 26.7.0 — fixed in 26.7.0
How to fix
Upgrade to a fixed version: librenms 26.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-7cj5-v4pp-v632
- https://www.vulncheck.com/advisories/librenms-before-26.7.0-stored-xss-via-graph-descr-settings
- https://github.com/librenms/librenms/security/advisories/GHSA-7cj5-v4pp-v632
Get alerted when CVE-2026-84188 or the next vulnerability affects your stack