What’s Vulnerable › Vulnerabilities
CVE-2026-84190: LibreNMS before 26.5.0 Remote Code Execution via AboutController
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-10-08
- Weakness: CWE-77
Description
LibreNMS versions before 26.5.0 contain a remote code execution vulnerability in the AboutController where the snmpget configuration parameter is passed to shell_exec() without proper validation. An authenticated administrator can modify the snmpget configuration to point to a malicious executable file and trigger code execution by accessing the /about endpoint.
Affected products
- librenms: before 26.5.0 — fixed in 26.5.0
How to fix
Upgrade to a fixed version: librenms 26.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-jf24-8g2h-2wg7
- https://www.vulncheck.com/advisories/librenms-before-26.5.0-remote-code-execution-via-aboutcontroller
- https://github.com/librenms/librenms/security/advisories/GHSA-jf24-8g2h-2wg7
Get alerted when CVE-2026-84190 or the next vulnerability affects your stack