What’s Vulnerable › Vulnerabilities
CVE-2026-84191: LibreNMS before 26.5.0 Stored XSS via SNMP VRF fields
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-09-08
- Weakness: CWE-79
Description
LibreNMS before 26.5.0 contains stored cross-site scripting vulnerabilities in VRF display pages where mplsVpnVrfDescription, vrf_name, and mplsVpnVrfRouteDistinguisher fields from SNMP polling are rendered without sanitization. Attackers controlling a monitored network device can inject arbitrary JavaScript through SNMP responses that executes in the browser of any user viewing VRF-related pages.
Affected products
- librenms: before 26.5.0 — fixed in 26.5.0
How to fix
Upgrade to a fixed version: librenms 26.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-g993-wffj-m3gv
- https://www.vulncheck.com/advisories/librenms-before-26.5.0-stored-xss-via-snmp-vrf-fields
Get alerted when CVE-2026-84191 or the next vulnerability affects your stack