What’s Vulnerable › Vulnerabilities
CVE-2026-84192: LibreNMS before 26.3.1 Stored XSS via SNMP/Syslog Data
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-10-08
- Weakness: CWE-79
Description
LibreNMS before 26.3.1 contains a stored cross-site scripting vulnerability in legacy PHP templates that output SNMP-sourced and syslog-sourced data without escaping. An attacker who controls a monitored network device can inject arbitrary JavaScript through SNMP interface descriptions or syslog program fields that executes when authenticated users view affected pages.
Affected products
- librenms: before 26.3.1 — fixed in 26.3.1
How to fix
Upgrade to a fixed version: librenms 26.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-7w8c-qgxg-m7jx
- https://www.vulncheck.com/advisories/librenms-before-26.3.1-stored-xss-via-snmp-syslog-data
- https://github.com/librenms/librenms/security/advisories/GHSA-7w8c-qgxg-m7jx
Get alerted when CVE-2026-84192 or the next vulnerability affects your stack