What’s Vulnerable › Vulnerabilities
CVE-2026-84196: Kyverno before 1.18.0 Server-Side Request Forgery via apiCall
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-09-10
- Weakness: CWE-918
Description
Kyverno before 1.18.0 contains a server-side request forgery vulnerability in apiCall.service.url that allows authenticated users to send arbitrary HTTP requests by injecting user-controlled input through variable substitution. Attackers can target internal services, cloud metadata endpoints, and loopback addresses, with response data reflected in admission error messages enabling non-blind data exfiltration.
Affected products
- kyverno: before 1.18.0 — fixed in 1.18.0
How to fix
Upgrade to a fixed version: kyverno 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/kyverno/kyverno/security/advisories/GHSA-qr4g-8hrp-c4rw
- https://www.vulncheck.com/advisories/kyverno-before-1.18.0-server-side-request-forgery-via-apicall
Get alerted when CVE-2026-84196 or the next vulnerability affects your stack