What’s Vulnerable › Vulnerabilities
CVE-2026-84199: Kyverno before 1.16.2 SSRF via APICall Feature
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-10-08
- Weakness: CWE-918
Description
Kyverno before 1.16.2 contains a server-side request forgery (SSRF) vulnerability in the APICall feature. The URL field in a Policy's ServiceCall configuration is not validated, so a user with namespace-level Policy creation permissions can direct Kyverno to make HTTP requests to arbitrary internal resources (e.g., cloud metadata endpoints such as 169.254.169.254 or other tenants' resources). Because Kyverno executes these requests using its cluster-wide high-privilege ServiceAccount (a Confused Deputy problem), the responses—potentially including other tenants' secrets and cloud IAM credentials—are returned in the PolicyReport and can be read by the attacker, breaking multi-tenant isolation.
Affected products
- kyverno: before 1.16.2 — fixed in 1.16.2
How to fix
Upgrade to a fixed version: kyverno 1.16.2. Check the vendor advisory for mitigations.
References
- https://github.com/kyverno/kyverno/security/advisories/GHSA-fmqp-4wfc-w3v7
- https://www.vulncheck.com/advisories/kyverno-before-1.16.2-ssrf-via-apicall-feature
- https://github.com/kyverno/kyverno/security/advisories/GHSA-fmqp-4wfc-w3v7
Get alerted when CVE-2026-84199 or the next vulnerability affects your stack