What’s Vulnerable › Vulnerabilities
CVE-2026-84207: Heym before 0.0.98 SSRF via WebSocket endpoints
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-09-08
- Weakness: CWE-918
Description
Heym before 0.0.98 fails to apply SSRF egress guards to WebSocket Send and WebSocket Trigger nodes, allowing authenticated users to connect to internal services. Attackers can craft workflow nodes with arbitrary URLs and headers to reach internal services and read responses from the WebSocket Trigger node.
Affected products
- heymrun heym: before 0.0.98 — fixed in 0.0.98
How to fix
Upgrade to a fixed version: heymrun heym 0.0.98. Check the vendor advisory for mitigations.
References
- https://github.com/heymrun/heym
- https://github.com/heymrun/heym/blob/v0.0.97/backend/app/services/websocket_trigger_service.py
- https://github.com/heymrun/heym/blob/v0.0.97/backend/app/services/websocket_utils.py
- https://github.com/heymrun/heym/commit/540aade7c7495295062f32f4dfd0d6805f066f0c
- https://github.com/heymrun/heym/releases/tag/v0.0.98
- https://github.com/heymrun/heym/security/advisories/GHSA-mqw6-g845-w596
- https://www.vulncheck.com/advisories/heym-before-0.0.98-ssrf-via-websocket-endpoints
Get alerted when CVE-2026-84207 or the next vulnerability affects your stack