What’s Vulnerable › Vulnerabilities
CVE-2026-84219: Kirki 6.2.1 - 6.2.5 - Unauthenticated Stored XSS via HTML Entity Decoding
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-06 · updated 2026-09-08
- Weakness: CWE-79
Description
The Kirki WordPress plugin before 6.3.0 does not hold back every spelling of the HTML entities it decodes when rendering, allowing unauthenticated users to store JavaScript in a comment which then runs in the session of anyone viewing a page that displays it, including an administrator, and on every page of the site when its header or footer is built to show comments.
Affected products
- Kirki: from 6.2.1 before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: Kirki 6.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84219 or the next vulnerability affects your stack