What’s Vulnerable › Vulnerabilities
CVE-2026-84268: Gvfs: sftp: heap-based buffer overflow in read_reply()
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-10-21
- Weakness: CWE-122
Description
A flaw was found in the SFTP backend in gvfs. When mounting a share and reading a file, a malicious SFTP server can cause read_reply() to process a length that exceeds the size requested by the client. The function does not verify the server-provided length against the allocated buffer size, causing the operation to write past the intended boundaries. This issue allows a malicious server to corrupt adjacent heap memory in the gvfsd-sftp process, resulting in a denial of service as the process aborts upon detecting the heap corruption or potentially allowing arbitrary code execution.
Affected products
- GNOME gvfs: before 1.60.2 — fixed in 1.60.2
- Red Hat Enterprise Linux 10: all versions — fixed in 0:1.54.4-4.el10_2.1
- Red Hat Enterprise Linux 10.0 Extended Update Support: all versions — fixed in 0:1.54.4-2.el10_0.2
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:1.36.2-7.el7_9.1
- Red Hat Enterprise Linux 8: all versions — fixed in 0:1.36.2-22.el8_10
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:1.36.2-11.el8_4.1
- Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On: all versions — fixed in 0:1.36.2-11.el8_4.1
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:1.36.2-11.el8_6.1
- Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On: all versions — fixed in 0:1.36.2-11.el8_6.1
- Red Hat Enterprise Linux 8.8 Telecommunications Update Service: all versions — fixed in 0:1.36.2-14.el8_8.1
- Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions: all versions — fixed in 0:1.36.2-14.el8_8.1
- Red Hat Enterprise Linux 9: all versions — fixed in 0:1.48.1-8.el9_8.1
- Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions: all versions — fixed in 0:1.48.1-4.el9_2.1
- Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions: all versions — fixed in 0:1.48.1-4.el9_4.1
- Red Hat Enterprise Linux 9.6 Extended Update Support: all versions — fixed in 0:1.48.1-6.el9_6.1
How to fix
Upgrade to a fixed version: GNOME gvfs 1.60.2; Red Hat Enterprise Linux 10 0:1.54.4-4.el10_2.1; Red Hat Enterprise Linux 10.0 Extended Update Support 0:1.54.4-2.el10_0.2; Red Hat Enterprise Linux 7 Extended Lifecycle Support 0:1.36.2-7.el7_9.1; Red Hat Enterprise Linux 8 0:1.36.2-22.el8_10; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 0:1.36.2-11.el8_4.1; Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On 0:1.36.2-11.el8_4.1; Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support 0:1.36.2-11.el8_6.1; Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On 0:1.36.2-11.el8_6.1; Red Hat Enterprise Linux 8.8 Telecommunications Update Service 0:1.36.2-14.el8_8.1; Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions 0:1.36.2-14.el8_8.1; Red Hat Enterprise Linux 9 0:1.48.1-8.el9_8.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:73997
- https://access.redhat.com/errata/RHSA-2026:73998
- https://access.redhat.com/errata/RHSA-2026:74370
- https://access.redhat.com/errata/RHSA-2026:85939
- https://access.redhat.com/errata/RHSA-2026:85940
- https://access.redhat.com/errata/RHSA-2026:85941
- https://access.redhat.com/errata/RHSA-2026:85942
- https://access.redhat.com/errata/RHSA-2026:85943
- https://access.redhat.com/errata/RHSA-2026:85944
- https://access.redhat.com/errata/RHSA-2026:85945
- https://access.redhat.com/errata/RHSA-2026:86606
- https://access.redhat.com/security/cve/CVE-2026-84268
Get alerted when CVE-2026-84268 or the next vulnerability affects your stack