What’s Vulnerable › Vulnerabilities
CVE-2026-84269: Gvfs: afp: heap-based buffer overflow in dsi read path
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-09-04
- Weakness: CWE-122
Description
A flaw was found in the AFP backend in gvfs. When mounting a share, a malicious AFP server can cause the DSI read path to process a length that exceeds the size requested by the client. The function does not verify the server-provided length against the pre-sized reply buffer, causing the operation to access past the intended boundaries. This issue allows a malicious server to overflow a heap buffer and crash the gvfsd-afp process, resulting in a denial of service.
Affected products
- GNOME gvfs: before 1.60.2 — fixed in 1.60.2
- Red Hat Enterprise Linux 10: all versions
- Red Hat Enterprise Linux 7: all versions
- Red Hat Enterprise Linux 8: all versions
- Red Hat Enterprise Linux 9: all versions
How to fix
Upgrade to a fixed version: GNOME gvfs 1.60.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2026-84269
- https://bugzilla.redhat.com/show_bug.cgi?id=2526784
- https://gitlab.gnome.org/GNOME/gvfs/-/issues/863
- https://gitlab.gnome.org/GNOME/gvfs/-/issues/863
Get alerted when CVE-2026-84269 or the next vulnerability affects your stack