What’s Vulnerable › Vulnerabilities
CVE-2026-8428: CSRF token is not validated in the core CMS update controller for Concrete CMS 9.5.0 and below
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-21 · updated 2026-07-23
- Weakness: CWE-352
Description
Concrete CMS 9.5.0 and below emits a CSRF token in the local_available_update.php view ($token->output('do_update')) but the corresponding do_update() method in concrete/controllers/single_page/dashboard/system/update/update.php never calls $this->token->validate('do_update'). The form is rendered as a POST form, meaning the token reaches the browser, but because the controller discards it without verification, an attacker can craft a cross-site POST that triggers a core CMS update to an attacker-specified version string. In order to be vulnerable, theictim must be passing canUpgrade()anda valid update version must be present under DIR_CORE_UPDATES. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks https://github.com/maru1009 for reporting.
Affected products
- Concrete CMS: before 9.5.1 — fixed in 9.5.1
How to fix
Upgrade to a fixed version: Concrete CMS 9.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8428 or the next vulnerability affects your stack