What’s Vulnerable › Vulnerabilities
CVE-2026-8430: SPIP < 4.4.14 Remote Code Execution via nginx
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-06-17
- Weakness: CWE-94
Description
SPIP versions prior to 4.4.14 contain a remote code execution vulnerability in the public space that is limited to certain nginx configurations, allowing attackers to execute arbitrary code in the context of the web server. Attackers can exploit this vulnerability through specific nginx configuration scenarios to achieve code execution, and this issue is not mitigated by the SPIP security screen.
Affected products
- SPIP: before 4.4.14 — fixed in 4.4.14
How to fix
Upgrade to a fixed version: SPIP 4.4.14. Check the vendor advisory for mitigations.
References
- https://blog.spip.net/
- https://www.vulncheck.com/advisories/spip-prior-to-remote-code-execution-via-nginx
Get alerted when CVE-2026-8430 or the next vulnerability affects your stack