What’s Vulnerable › Vulnerabilities

CVE-2026-8435: Concrete CMS 9 before 9.5.0 is vulnerable to Cross Site Request Forgery (CSRF) at concrete/controllers/backend/file approveVersion()

Description

Concrete CMS 9 before 9.5.0 is vulnerable to Cross Site Request Forgery (CSRF) at concrete/controllers/backend/file approveVersion(). The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.3 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks Yonatan Drori (Tenzai) for reporting.

Affected products

How to fix

Upgrade to a fixed version: Concrete CMS 9.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-8435 or the next vulnerability affects your stack