What’s Vulnerable › Vulnerabilities
CVE-2026-84360: Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-288
Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.
Affected products
- 0xJacky nginx-ui: before 2.4.1
References
- https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-vc32-4gwf-77xp
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-vc32-4gwf-77xp
Get alerted when CVE-2026-84360 or the next vulnerability affects your stack