What’s Vulnerable › Vulnerabilities
CVE-2026-84439: Apache ZooKeeper: Audit log injection via unsanitized output from multiple sources
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-18
- Weakness: CWE-117
Description
When audit logging is enabled (zookeeper.audit.enable=true), an unauthenticated attacker can inject arbitrary fields into Apache ZooKeeper's audit log by sending a digest authentication request with tab characters (\t) embedded in the username. Because the audit log uses tab-separated key=value format, the injected tabs are parsed as legitimate field separators, allowing the attacker to spoof audit results (e.g., injecting result=success), forge operation types, and corrupt forensic evidence. A log injection vulnerability in Apache ZooKeeper allows a client that can call setACL to inject forged key-value fields into zookeeper_audit.log. When audit logging is enabled, the server serializes attacker-controlled digest ACL ids into the acl= audit field without escaping tab characters. Because audit events are emitted as tab-separated key=value records, a crafted ACL id can make one successful setAcl event appear to contain forged fields such as operation=delete and znode=/forged. This undermines the integrity of downstream audit parsing, alerting, and incident response. This issue affects Apache ZooKeeper: from 3.9.0 through 3.9.5, from 3.8.0 through 3.8.6. Users are recommended to upgrade to version 3.9.6 or 3.8.7, which fixes the issue.
Affected products
- Apache Software Foundation Apache ZooKeeper: from 3.8.0 before 3.8.7; from 3.9.0 before 3.9.6 — fixed in 3.8.7, 3.9.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ZooKeeper 3.8.7, 3.9.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/b7qnjvqjh393l0j07tmnb5ggg40sx3m6
- http://www.openwall.com/lists/oss-security/2026/09/15/6
Get alerted when CVE-2026-84439 or the next vulnerability affects your stack