What’s Vulnerable › Vulnerabilities
CVE-2026-8447: Langflow is vulnerable to stored cross-site scripting and IP spoofing due to unsanitized Markdown rendering and untrusted proxy header trust
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-79
Description
IBM Langflow OSS 1.0.0 through 1.11.2 suffer from a stored cross-site scripting vulnerability in the Playground chat interface.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.3 — fixed in 1.11.3
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8447 or the next vulnerability affects your stack