What’s Vulnerable › Vulnerabilities
CVE-2026-8461: Heap out-of-bounds write via odd slice_height in FFmpeg MagicYUV decoder
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-18 · updated 2026-07-23
- Weakness: CWE-787
Description
An out-of-bounds write vulnerability in FFmpeg's libavcodec library, specifically in the MagicYUV decoder, allows denial-of-service and, in some cases, can be exploited for remote code execution. This vulnerability is associated with the file libavcodec/magicyuv.C. This issue affects FFmpeg before version 8.1.2.
Affected products
- FFmpeg: before 8.1.2 — fixed in 8.1.2
How to fix
Upgrade to a fixed version: FFmpeg 8.1.2. Check the vendor advisory for mitigations.
References
- https://code.ffmpeg.org/FFmpeg/FFmpeg/pulls/23159
- https://access.redhat.com/errata/RHSA-2026:43711
- https://access.redhat.com/security/cve/CVE-2026-8461
- https://bugzilla.redhat.com/show_bug.cgi?id=2490308
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-8461.json
Get alerted when CVE-2026-8461 or the next vulnerability affects your stack