What’s Vulnerable › Vulnerabilities

CVE-2026-84648

Description

In Jenkins 2.579 and earlier, LTS 2.568.2 and earlier, the system log viewer does not escape log record metadata (source, level, and timestamp) resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers in control of agent processes.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.568.3, 2.580. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-84648 or the next vulnerability affects your stack