What’s Vulnerable › Vulnerabilities

CVE-2026-84650

Description

In Jenkins 2.579 and earlier, LTS 2.568.2 and earlier, transient fields cannot be excluded from deserialization, allowing attackers able to submit configuration updates to specify the values of transient fields that will be deserialized, the impact depending on how those fields are used.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.568.3, 2.580. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-84650 or the next vulnerability affects your stack