What’s Vulnerable › Vulnerabilities
CVE-2026-8470: Langflow is affected by weaknesses in secret handling and sensitive configuration access
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-24
- Weakness: CWE-327
Description
IBM Langflow OSS 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, and 1.0.0 through 1.10.3 use Python's non-cryptographic random module for generating Fernet encryption keys from user secrets under 32 characters. The deterministic Mersenne Twister PRNG produces identical keys for identical seeds, allowing attackers to reproduce encryption keys and decrypt stored API keys and authentication tokens.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8470 or the next vulnerability affects your stack