What’s Vulnerable › Vulnerabilities
CVE-2026-84702: facefusion before 3.7.0 Path Traversal via Job Identifier
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-23
- Weakness: CWE-22
Description
facefusion through 3.6.1 fails to normalize job identifiers in get_job_file_name, allowing attackers to write files outside the jobs directory. Attackers can supply traversal sequences in the job identifier parameter through the unauthenticated HTTP API to create files at arbitrary locations.
Affected products
- facefusion: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: facefusion 3.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/facefusion/facefusion
- https://github.com/facefusion/facefusion/blob/3.6.1/facefusion/jobs/job_manager.py
- https://github.com/facefusion/facefusion/commit/a2cbfd73b10191e51ed2eb1e83c19121153e0a22
- https://github.com/facefusion/facefusion/releases/tag/3.7.0
- https://github.com/geo-chen/oss/blob/main/facefusion.md
- https://www.vulncheck.com/advisories/facefusion-before-3.7.0-path-traversal-via-job-identifier
- https://github.com/geo-chen/oss/blob/main/facefusion.md
Get alerted when CVE-2026-84702 or the next vulnerability affects your stack