What’s Vulnerable › Vulnerabilities
CVE-2026-84715: FeatherPanel before 1.3.7.10 Privilege Escalation via Subuser Permission Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-10
- Weakness: CWE-862
Description
FeatherPanel versions before 1.3.7.10 fail to validate permissions in the SubuserController updateSubuser handler, allowing authenticated subusers to modify their own permission records. A subuser with minimal permissions can send a crafted request to grant themselves full server control, enabling unauthorized access to sensitive data, backups, and server configuration.
Affected products
- MythicalLTD FeatherPanel: before 1.3.7.10 — fixed in 1.3.7.10
How to fix
Upgrade to a fixed version: MythicalLTD FeatherPanel 1.3.7.10. Check the vendor advisory for mitigations.
References
- https://github.com/MythicalLTD/FeatherPanel
- https://github.com/MythicalLTD/FeatherPanel/blob/376b003aa9685b74153d239d2b3f64a752cdc0f0/backend/app/Controllers/User/Server/SubuserController.php#L454
- https://github.com/MythicalLTD/FeatherPanel/blob/376b003aa9685b74153d239d2b3f64a752cdc0f0/backend/app/Helpers/ServerGateway.php
- https://github.com/MythicalLTD/FeatherPanel/commit/06ef8dcac471201748516ca743694159cb846a9d
- https://github.com/MythicalLTD/FeatherPanel/releases/tag/v1.3.7.10
- https://www.vulncheck.com/advisories/featherpanel-before-1.3.7.10-privilege-escalation-via-subuser-permission-update
Get alerted when CVE-2026-84715 or the next vulnerability affects your stack