What’s Vulnerable › Vulnerabilities
CVE-2026-84738: AF Companion < 2.2.0 - Shop Manager+ Arbitrary File Upload to RCE
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-18
- Weakness: CWE-94
Description
The AF Companion WordPress plugin before 2.2.0 does not validate the type of files uploaded through one of its import features, allowing users with a low-privileged store-management role to upload arbitrary files, including PHP ones, leading to Remote Code Execution.
Affected products
- AF Companion: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: AF Companion 2.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84738 or the next vulnerability affects your stack