What’s Vulnerable › Vulnerabilities

CVE-2026-84739: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.11 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to execute arbitrary JavaScript in the context of another user's browser session due to improper sanitization of path components in the merge request diff viewer.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.2.7, 19.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-84739 or the next vulnerability affects your stack