What’s Vulnerable › Vulnerabilities
CVE-2026-84740: The Events Calendar 6.12.0 - 6.17.5 - Unauthenticated Arbitrary Shortcode Execution via 'view_data' Parameter
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-74
Description
The Events Calendar WordPress plugin before 6.17.5.1 does not validate or sanitise data submitted to an unauthenticated AJAX action before merging it into its rendering context, allowing unauthenticated users to execute arbitrary shortcodes registered on the site.
Affected products
- stellarwp The Events Calendar: from 6.12.0 before 6.17.5.1 — fixed in 6.17.5.1
How to fix
Upgrade to a fixed version: stellarwp The Events Calendar 6.17.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84740 or the next vulnerability affects your stack