What’s Vulnerable › Vulnerabilities
CVE-2026-84742: The Events Calendar 6.15.0 - 6.17.4.1 - Contributor+ Content Publication via TEC V1 REST API
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-863
Description
The Events Calendar WordPress plugin before 6.17.5 does not check the capability required to publish content before creating or updating it through its REST API, allowing users with a role that cannot normally publish, such as contributor, to publish content directly and bypass editorial review.
Affected products
- stellarwp The Events Calendar: from 6.15.0 before 6.17.5 — fixed in 6.17.5
How to fix
Upgrade to a fixed version: stellarwp The Events Calendar 6.17.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84742 or the next vulnerability affects your stack