What’s Vulnerable › Vulnerabilities
CVE-2026-8481: Remote Code Execution via Code Validation Endpoint
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-94
Description
IBM Langflow OSS 1.0.0 through 1.10.0 contain a critical remote code execution vulnerability in the code validation API endpoint. The POST /api/v1/validate/code endpoint accepts user-supplied Python code and executes it directly using Python's built-in exec() function without sandboxing, input validation, or privilege restrictions, enabling any authenticated user to execute arbitrary system commands with the full privileges of the Langflow server process.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.1 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8481 or the next vulnerability affects your stack