What’s Vulnerable › Vulnerabilities
CVE-2026-84829: Optimole < 4.2.12 - Unauthenticated Stored XSS via Srcset Descriptor Parameter
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-17
- Weakness: CWE-79
Description
The Optimole WordPress plugin before 4.2.12 does not properly escape a user supplied value before using it to build an image tag attribute, allowing unauthenticated users to inject arbitrary attributes into pages served to every visitor, which leads to Stored Cross-Site Scripting.
Affected products
- Optimole: from 4.2.3 before 4.2.12 — fixed in 4.2.12
How to fix
Upgrade to a fixed version: Optimole 4.2.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84829 or the next vulnerability affects your stack