What’s Vulnerable › Vulnerabilities
CVE-2026-84890: undici vulnerable to Denial of Service via unbounded decompression of compressed responses
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-11
- Weakness: CWE-770
Description
undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Affected products
- undici: from 7.15.0 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 7.29.1, 8.10.2
- Npm Undici: from 7.15.0 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 7.29.1, 8.10.2
How to fix
Upgrade to a fixed version: undici 7.29.1, 8.10.2; Npm Undici 7.29.1, 8.10.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-3xpg-4rpp-hhhm
Get alerted when CVE-2026-84890 or the next vulnerability affects your stack