What’s Vulnerable › Vulnerabilities
CVE-2026-84899: VikWidgetsLoader < 1.12.0 - Contributor+ Stored XSS via Gutenberg Block class_suffix
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-08
- Weakness: CWE-79
Description
The VikWidgetsLoader WordPress plugin before 1.12.0 does not sanitise or escape a block attribute before outputting it inside an inline script, allowing users with the Contributor role to store arbitrary JavaScript that executes in the browser of any user viewing the affected post, including the administrator who reviews the pending submission.
Affected products
- VikWidgetsLoader: from 1.11.0 before 1.12.0 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: VikWidgetsLoader 1.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84899 or the next vulnerability affects your stack