What’s Vulnerable › Vulnerabilities
CVE-2026-84902: King Addons for Elementor < 51.1.81 - Contributor+ Stored XSS via Template Catalog Import
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-18
- Weakness: CWE-79
Description
The King Addons for Elementor WordPress plugin before 51.1.81 does not perform an object-level authorization check when importing template content into a page, allowing users with contributor-level access and above to overwrite the Elementor content of arbitrary posts and pages, including those owned by administrators, and to inject JavaScript through a widget setting that is output without escaping, resulting in Stored Cross-Site Scripting that executes in the session of any user who views the affected page.
Affected products
- King Addons for Elementor: before 51.1.81 — fixed in 51.1.81
How to fix
Upgrade to a fixed version: King Addons for Elementor 51.1.81. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84902 or the next vulnerability affects your stack