What’s Vulnerable › Vulnerabilities
CVE-2026-84915: Component blocks - Moderately critical - Cross site scripting - SA-CONTRIB-2026-123
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Component blocks allows Stored XSS. This issue affects Component blocks versions: from 0.0.0 to 1.2.7.
Affected products
- Drupal Component blocks: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: Drupal Component blocks 1.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84915 or the next vulnerability affects your stack