What’s Vulnerable › Vulnerabilities
CVE-2026-84919: PhotoSwipe - Responsive JavaScript Modal Image Gallery - Moderately critical - Cross-site scripting - SA-CONTRIB-2026-131
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal PhotoSwipe - Responsive JavaScript Modal Image Gallery allows Stored XSS. This issue affects PhotoSwipe - Responsive JavaScript Modal Image Gallery versions: from 0.0.0 to 5.0.9.
Affected products
- Drupal PhotoSwipe - Responsive JavaScript Modal Image Gallery: before 5.0.9 — fixed in 5.0.9
How to fix
Upgrade to a fixed version: Drupal PhotoSwipe - Responsive JavaScript Modal Image Gallery 5.0.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84919 or the next vulnerability affects your stack