What’s Vulnerable › Vulnerabilities
CVE-2026-84924: Email Verification / SMS Verification / OTP Verification - Critical - Cross Site Scripting - SA-CONTRIB-2026-125
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Email Verification / SMS Verification / OTP Verification allows Reflected XSS. This issue affects Email Verification / SMS Verification / OTP Verification versions: from 0.0.0 to 2.4.0.
Affected products
- Drupal Email Verification / SMS Verification / OTP Verification: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Drupal Email Verification / SMS Verification / OTP Verification 2.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84924 or the next vulnerability affects your stack