What’s Vulnerable › Vulnerabilities
CVE-2026-84933: undici vulnerable to cross-user cookie disclosure via Set-Cookie caching in shared caches
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-15
- Weakness: CWE-200
Description
undici's cache interceptor does not handle the Set-Cookie response header anywhere in its cache path, so it neither refuses to store nor strips that header. In shared cache mode, which is the default, an otherwise cacheable response that carries a Set-Cookie header, for example one marked with a public and max-age directive, is stored and then re-served to a later caller that matches the same cache key. As a result one caller's cookie is disclosed to a different caller, and an untrusted server can inject cookies into cached responses served to all subsequent callers. This violates the requirement that a shared cache must not store cookies. This affects undici versions from 7.0.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Affected products
- undici: from 7.0.0 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 7.29.1, 8.10.2
- Npm Undici: from 7.0.0 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 7.29.1, 8.10.2
How to fix
Upgrade to a fixed version: undici 7.29.1, 8.10.2; Npm Undici 7.29.1, 8.10.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-2jfj-6hjv-fm6j
Get alerted when CVE-2026-84933 or the next vulnerability affects your stack