What’s Vulnerable › Vulnerabilities
CVE-2026-84934: JCH Optimize < 6.0.1 - Subscriber+ Stored XSS via getcacheinfo Task Override
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-08
- Weakness: CWE-79
Description
The JCH Optimize WordPress plugin before 6.0.1 does not perform a capability check on one of its authenticated AJAX actions and lets the request choose which internal action runs, allowing any authenticated users such as Subscribers to import arbitrary JCH Optimize WordPress plugin before 6.0.1 settings and store a script that executes in the browser of any visitor or administrator viewing the site.
Affected products
- JCH Optimize: before 6.0.1 — fixed in 6.0.1
How to fix
Upgrade to a fixed version: JCH Optimize 6.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84934 or the next vulnerability affects your stack