What’s Vulnerable › Vulnerabilities
CVE-2026-84935: HT Menu < 1.2.7 - Subscriber+ Stored XSS via Menu Settings
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-08
- Weakness: CWE-79
Description
The HT Menu WordPress plugin before 1.2.7 does not perform any capability or object-ownership check when saving navigation menu-item settings, and does not escape those stored settings when the menu is rendered, allowing users with minimal permissions such as Subscribers to store JavaScript that executes in the browser of any visitor, administrators included, who views the affected menu.
Affected products
- HT Menu: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: HT Menu 1.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84935 or the next vulnerability affects your stack