What’s Vulnerable › Vulnerabilities
CVE-2026-84961: undici vulnerable to TLS certificate validation bypass via dropped connect options in BalancedPool
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-15
- Weakness: CWE-295
Description
undici's BalancedPool constructor passes its entire options object through an internal deep-clone that serializes and reparses the value as JSON. Because JSON cannot represent functions, any function-valued TLS option, such as a caller-supplied checkServerIdentity callback or a custom connector inside the connect option, is silently discarded before it reaches the TLS layer. As a result a peer whose certificate the application's custom checkServerIdentity was written to reject, but which still passes Node's default hostname and chain checks, is accepted when reached through BalancedPool. The Client, Pool, and Agent dispatchers are not affected because they extract the connect and tls options before cloning. This affects undici versions from 7.24.1 up to 7.29.1 and from 8.0.0 up to 8.10.2, and only when the application supplies a function-valued connect or tls option to BalancedPool. Users should upgrade to undici 7.29.1 or 8.10.2.
Affected products
- undici: from 7.24.1 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 7.29.1, 8.10.2
- Npm Undici: from 7.24.1 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 7.29.1, 8.10.2
How to fix
Upgrade to a fixed version: undici 7.29.1, 8.10.2; Npm Undici 7.29.1, 8.10.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-w293-vg96-wgc3
Get alerted when CVE-2026-84961 or the next vulnerability affects your stack