What’s Vulnerable › Vulnerabilities
CVE-2026-84968: Heap out-of-bounds read via corrupt nested BSON in field path error message
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-10
- Weakness: CWE-125
Description
An out-of-bounds read in the BSON decoding component of the MongoDB PHP driver may allow an unauthenticated party who supplies specially formed input to have a small amount of adjacent process memory copied into an error message that is returned to application code. This may result in unintended disclosure of limited memory contents.
Affected products
- MongoDB PHP Driver: from 1.15.0 before 1.21.9; from 2.0.0 before 2.1.9; from 2.2.0 before 2.5.2 — fixed in 1.21.9, 2.1.9, 2.5.2
How to fix
Upgrade to a fixed version: MongoDB PHP Driver 1.21.9, 2.1.9, 2.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-84968 or the next vulnerability affects your stack