What’s Vulnerable › Vulnerabilities
CVE-2026-85024: undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-16
- Weakness: CWE-248
Description
undici bundles a WebSocket client whose permessage-deflate size-limit cleanup removes all listeners from the internal zlib inflate stream, including its error listener, while that stream can still emit. When a remote peer sends a compressed payload that crosses the built-in 128 MiB decompressed-payload limit and then contains a malformed DEFLATE byte, the inflate stream emits a data error with no listener attached, which Node.js treats as a fatal unhandled error and terminates the entire process. Exploitation is remote and unauthenticated, requires no application mistake, and is asymmetric, since roughly 130 KB on the wire expands past the limit and crashes the process, and reconnecting can repeat the crash. This affects undici versions from 6.25.0 up to 6.28.1, from 7.28.0 up to 7.29.1, and from 8.1.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Affected products
- undici: from 6.25.0 before 6.28.1; from 7.28.0 before 7.29.1; from 8.1.0 before 8.10.2 — fixed in 6.28.1, 7.29.1, 8.10.2
- Npm Undici: from 6.25.0 before 6.28.1; from 7.28.0 before 7.29.1; from 8.1.0 before 8.10.2 — fixed in 6.28.1, 7.29.1, 8.10.2
How to fix
Upgrade to a fixed version: undici 6.28.1, 7.29.1, 8.10.2; Npm Undici 6.28.1, 7.29.1, 8.10.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-3wwx-pv8p-q78v
Get alerted when CVE-2026-85024 or the next vulnerability affects your stack