What’s Vulnerable › Vulnerabilities
CVE-2026-85025: Langflow is vulnerable to arbitrary code execution due to multiple incomplete code security controls and missing execution guards
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-15
- Weakness: CWE-863
Description
IBM Langflow OSS 1.0.0 through 1.11.5 Langflow could allow an unauthenticated attacker to execute arbitrary code and access or modify chat sessions through publicly shared MCP project endpoints due to improper enforcement of public-flow security restrictions and session isolation controls.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.6 — fixed in 1.11.6
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-85025 or the next vulnerability affects your stack