What’s Vulnerable › Vulnerabilities
CVE-2026-85086: Apache Thrift: Perl TLS client disables certificate verification by default
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-295
Description
Improper certificate validation, Initialization of a resource with an insecure default vulnerability in Apache Thrift perl bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Thrift: before 0.25.0 — fixed in 0.25.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Thrift 0.25.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1
- https://lists.apache.org/thread/c7f9g4027ok0gocyso2y84r2mhgc2xmy
Get alerted when CVE-2026-85086 or the next vulnerability affects your stack